Update your Jomres installation from Joomla 3 to Joomla 4

More
2 months 1 week ago #47958 by Vince Wooll
While it is technically possible to update your J3 installation to J4, it can be a tricky process because some extensions you may have installed over the years may not be compatible with Joomla 4. If you're going to attempt it, I would recommend that you use Akeeba backup to first make a copy of your site as a Staging server. Once you've done that you can experiment with updating your site on another machine that doesn't affect your production installation.

Important: The older Leohtian template is NOT compatible with Joomla 4. Unfortunately this means that a Leohtian installation will not be a simple update.

You will need a new template, one that's confirmed to work with J4. The default J4 Cassiopeia template is excellent, you can customise that if you feel comfortable doing so. You can create a child template of Cassiopeia and work with that to ensure that you can update Joomla in the future without fear of your template customisations being lost.


Jomres is cross-platform compatible. This means that providing your installation of Jomres and it's plugins are up-to-date, then you can update Joomla.

Once you have setup your Staging server, you should do things in this order :
  • Make sure that Jomres and its plugins are up-to-date. In Site Configuration change the template version of Jomres to Bootstrap 5.
  • Update any other plugins that you can update.
  • Start the Joomla 4 update process. Take care to uninstall any plugins that cannot be confirmed as compatible with Joomla 4.

Once the update has been completed and you've worked through any issues you will need to re-configure your site to work with your new template.







 

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

ABOUT US

vince picDeveloped and maintained by Vince Wooll, Jomres was initially conceived in early 2005 as a Mambo based solution to a client’s hotel management needs. While it wasn't originally expected to be an online booking system it quickly morphed into one as users requested more and more features.

As the number of feature requests grew Vince knew that he would need to dedicate more time to the project and in July 2005 Jomres was released as a commercial project. Since then Jomres has become the world's oldest online booking plugin for any PHP CMS. It has been used in Joomla 1.0, 1.5, 2.5, 3 & 4 and WordPress 4, 5 & 6.

Aladar joined the project in 2010 after using Jomres for his own projects. He was active on the forum, helping other members of the community and eventually Vince invited him to join the team. Between 2010 and 2018 he was an integral part of the project and made many significant contributions.

Whilst not formally part of the Jomres project, Rodrigo Rocco and Vince have become firm friends. Rod is a freelancer who specialises in doing custom work for Jomres users and developing custom plugins for the system that take advantage of it's modular design. He has built many useful extensions including his fabulous Valentina Template Override Package.

Jomres and the Jomres Logo is trademarked and can't be used without written consent from the owner.

www.jomres.net is not affiliated with or endorsed by the Joomla! Project, Open Source Matters or the WordPress project. The Joomla! & WordPress names and logos are used under a limited license granted by Open Source Matters and the WordPress Projects.

© Copyright 2005 - 2022 Vince Wooll