Requirements

Minimum Server Requirements

You must already have a working installation of a CMS to install Jomres onto. Jomres by default supports all current versions of Joomla.

 

  • PHP 5.5.x or above

  • MySQL 4.1 or above

  • Apache 1.13.19 or above

  • php.ini memory_limit set to at least 32M, 128M recommended.

 

CMS versions

  • Joomla 1.5 This version of Jooma is no longer supported.

  • Joomla 1.6 This version of Jooma is no longer supported.

  • Joomla 1.7 This version of Jooma is no longer supported.

  • Joomla 2.5 This version of Jooma is no longer supported.

  • Joomla 3.x If you are starting a new project utilising Jomres, we recommend you install on Joomla 3.x. This is the newest flavour of Joomla, it offers support for responsive templates, meaning it's now almost trival to build websites that work well on both desktop and mobile devices.

  • Wordpress 4+

 

PHP Requirements

To use the full functionality of Jomres you will need the following PHP features/modules enabled:

 

  • CURL - Used for downloading all plugins including modules from the Jomres servers.
  • File system functions - Used for uploading of property and room images, writing temporary data etc. (required)
  • You must ensure that you have MySQL, XML and Zlib support built into PHP. (required)
  • MBString features must be enabled.
  • ZipArchive must be enabled.
  • GD must be enabled.

 

 

Whilst this list may look pretty daunting, most quality hosts will provide this functionality in a standard hosting package.

Max Input Vars

If you intend to install the Advanced/Micromanage tariff editing modes plugin, please be aware that it's recommended that you increase your PHP max_input_vars setting to something higher than the default 1000.

 

Jomres Manual